PING6(8) | System Manager's Manual | PING6(8) |
ping6
— send
ICMPv6 ECHO_REQUEST packets to network hosts
ping6 |
[-CDdfHmnNoqtvwW ]
[-a addrtype]
[-b bufsiz]
[-B boundif]
[-c count]
[-G sweepmaxsize[,sweepminsize[,sweepincrsize]]]
[-g gateway]
[-G sweep]
[-h hoplimit]
[-I interface]
[-i wait]
[-k trafficclass]
[-K netservicetype]
[-l preload]
[-P policy]
[-p pattern]
[-S sourceaddr]
[-s packetsize]
[-z tclass]
[--apple-connect ]
[--apple-time ]
[hops ...] host |
The ping6
utility uses the ICMPv6
protocol's mandatory ICMP6_ECHO_REQUEST datagram to elicit an
ICMP6_ECHO_REPLY from a host or gateway. ICMP6_ECHO_REQUEST datagrams
(``pings'') have an IPv6 header, and ICMPv6 header formatted as documented
in RFC2463. The options are as follows:
-a
addrtypea
c
g
s
l
A
-b
bufsiz-B
boundif-C
-c
count-D
-d
SO_DEBUG
option on the socket being
used.-f
-G
sweepmaxsize[,sweepminsize[,sweepincrsize]]-g
gateway-H
ping6
utility does not try reverse-lookup unless
the option is specified.-h
hoplimit-I
interface-i
wait-f
option.-k
trafficclassping6
uses the control traffic
class (CTL). This option is an Apple addition.-K
netservicetype-l
preloadping6
sends that many packets as fast as possible
before falling into its normal mode of behavior. Only the super-user may
use this option.-m
ping6
asks the kernel to fragment
packets to fit into the minimum IPv6 MTU. The -m
option will suppress the behavior in the following two levels: when the
option is specified once, the behavior will be disabled for unicast
packets. When the option is more than once, it will be disabled for both
unicast and multicast packets.-n
-N
ff02::2:xxxx:xxxx
). host
must be string hostname of the target (must not be a numeric IPv6
address). Node information multicast group will be computed based on given
host, and will be used as the final destination.
Since node information multicast group is a link-local multicast group,
outgoing interface needs to be specified by -I
option.-o
-p
pattern-p ff
” will
cause the sent packet to be filled with all ones.-P
policy-q
-r
-R
-S
sourceaddr-s
packetsize-b
as well to
extend socket buffer size.-t
-s
has no effect if
-t
is specified.-v
-w
-s
has no effect if -w
is
specified.-W
-w
, but with old packet format based on 03
draft. This option is present for backward compatibility.
-s
has no effect if -w
is
specified.-z
tclass--apple-connect
--apple-time
When using ping6
for fault isolation, it
should first be run on the local host, to verify that the local network
interface is up and running. Then, hosts and gateways further and further
away should be “pinged”. Round-trip times and packet loss
statistics are computed. If duplicate packets are received, they are not
included in the packet loss calculation, although the round trip time of
these packets is used in calculating the round-trip time statistics. When
the specified number of packets have been sent (and received) or if the
program is terminated with a SIGINT
, a brief summary
is displayed, showing the number of packets sent and received, and the
minimum, mean, maximum, and standard deviation of the round-trip times.
If ping6
receives a
SIGINFO
(see the status
argument for stty(1)) signal, the current
number of packets sent and received, and the minimum, mean, maximum, and
standard deviation of the round-trip times will be written to the standard
output in the same format as the standard completion message.
This program is intended for use in network testing, measurement
and management. Because of the load it can impose on the network, it is
unwise to use ping6
during normal operations or from
automated scripts.
The ping6
utility will report duplicate
and damaged packets. Duplicate packets should never occur when pinging a
unicast address, and seem to be caused by inappropriate link-level
retransmissions. Duplicates may occur in many situations and are rarely (if
ever) a good sign, although the presence of low levels of duplicates may not
always be cause for alarm. Duplicates are expected when pinging a broadcast
or multicast address, since they are not really duplicates but replies from
different hosts to the same request.
Damaged packets are obviously serious cause for alarm and often
indicate broken hardware somewhere in the ping6
packet's path (in the network or in the hosts).
The (inter)network layer should never treat packets differently depending on the data contained in the data portion. Unfortunately, data-dependent problems have been known to sneak into networks and remain undetected for long periods of time. In many cases the particular pattern that will have problems is something that does not have sufficient “transitions”, such as all ones or all zeros, or a pattern right at the edge, such as almost all zeros. It is not necessarily enough to specify a data pattern of all zeros (for example) on the command line because the pattern that is of interest is at the data link level, and the relationship between what you type and what the controllers transmit can be complicated.
This means that if you have a data-dependent problem you will
probably have to do a lot of testing to find it. If you are lucky, you may
manage to find a file that either cannot be sent across your network or that
takes much longer to transfer than other similar length files. You can then
examine this file for repeated patterns that you can test using the
-p
option of ping6
.
The ping6
utility returns 0 on success
(the host is alive), 2 if the transmission was successful but no responses
were received, any other non-zero value if the arguments are incorrect or
another error has occurred.
Normally, ping6
works just like
ping(8) would work; the following will
send ICMPv6 echo request to dst.foo.com
.
ping6 -n dst.foo.com
The following will probe hostnames for all nodes on the network
link attached to wi0
interface. The address
ff02::1
is named the link-local all-node multicast
address, and the packet would reach every node on the network link.
ping6 -w ff02::1%wi0
The following will probe addresses assigned to the destination
node, dst.foo.com
.
ping6 -a agl dst.foo.com
netstat(1), icmp6(4), inet6(4), ip6(4), ifconfig(8), ping(8), routed(8), traceroute(8), traceroute6(8)
A. Conta and S. Deering, Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification, RFC2463, December 1998.
Matt Crawford, IPv6 Node Information Queries, draft-ietf-ipngwg-icmp-name-lookups-09.txt, May 2002, work in progress material.
The ping(8) utility appeared in
4.3BSD. The ping6
utility
with IPv6 support first appeared in the WIDE Hydrangea IPv6 protocol stack
kit.
IPv6 and IPsec support based on the KAME Project (http://www.kame.net/) stack was initially integrated into FreeBSD 4.0.
The ping6
utility is intentionally
separate from ping(8).
There have been many discussions on why we separate
ping6
and
ping(8). Some people argued that it would
be more convenient to uniform the ping command for both IPv4 and IPv6.
The following are an answer to the request:
From a developer's point of view: since the underling raw sockets API is totally different between IPv4 and IPv6, we would end up having two types of code base. There would actually be less benefit to uniform the two commands into a single command from the developer's standpoint.
From an operator's point of view: unlike ordinary network
applications like remote login tools, we are usually aware of address family
when using network management tools. We do not just want to know the
reachability to the host, but want to know the reachability to the host via
a particular network protocol such as IPv6. Thus, even if we had a unified
ping(8) command for both IPv4 and IPv6,
we would usually type a -6
or
-4
option (or something like those) to specify the
particular address family. This essentially means that we have two different
commands.
March 29, 2013 | macOS 15.0 |