INET6(4) | Device Drivers Manual | INET6(4) |
inet6
— Internet
protocol version 6 family
#include
<sys/types.h>
#include <netinet/in.h>
The inet6
family is an updated version of
inet(4) family. While
inet(4) implements Internet Protocol
version 4, inet6
implements Internet Protocol
version 6.
inet6
is a collection of
protocols layered atop the
Internet Protocol
version 6 (IPv6) transport layer, and utilizing the IPv6 address
format. The inet6
family provides protocol support
for the SOCK_STREAM
,
SOCK_DGRAM
, and SOCK_RAW
socket types; the SOCK_RAW
interface provides access
to the IPv6 protocol.
IPv6 addresses are 16 byte quantities, stored in network standard byteorder. The include file ⟨netinet/in.h⟩ defines this address as a discriminated union.
Sockets bound to the inet6
family utilize
the following addressing structure:
struct sockaddr_in6 { u_int8_t sin6_len; u_int8_t sin6_family; u_int16_t sin6_port; u_int32_t sin6_flowinfo; struct in6_addr sin6_addr; u_int32_t sin6_scope_id; };
Sockets may be created with the local address
“::
” (which is equal to IPv6 address
0:0:0:0:0:0:0:0
) to affect “wildcard”
matching on incoming messages.
The IPv6 specification defines scoped addresses, like link-local or site-local addresses. A scoped address is ambiguous to the kernel, if it is specified without a scope identifier. To manipulate scoped addresses properly from the userland, programs must use the advanced API defined in RFC2292. A compact description of the advanced API is available in ip6(4). If a scoped address is specified without an explicit scope, the kernel may raise an error. Note that scoped addresses are not for daily use at this moment, both from a specification and an implementation point of view.
The KAME implementation supports an extended numeric IPv6 address
notation for link-local addresses, like
“fe80::1%de0
” to specify
“fe80::1
on de0
interface”. This notation is supported by
getaddrinfo(3) and
getnameinfo(3). Some of normal
userland programs, such as telnet(1) or
ftp(1), are able to use this notation.
With special programs like ping6(8), you
can specify the outgoing interface by an extra command line option to
disambiguate scoped addresses.
Scoped addresses are handled specially in the kernel. In kernel
structures like routing tables or interface structures, a scoped address
will have its interface index embedded into the address. Therefore, the
address in some kernel structures is not the same as that on the wire. The
embedded index will become visible through a
PF_ROUTE
socket, kernel memory accesses via
kvm(3) and on some other occasions.
HOWEVER, users should never use the embedded form. For details please
consult IMPLEMENTATION supplied with KAME kit.
The inet6
family is comprised of the IPv6
network protocol, Internet Control Message Protocol version 6 (ICMPv6),
Transmission Control Protocol (TCP), and User Datagram Protocol (UDP). TCP
is used to support the SOCK_STREAM
abstraction while
UDP is used to support the SOCK_DGRAM
abstraction.
Note that TCP and UDP are common to
inet(4) and
inet6
. A raw interface to IPv6 is available by
creating an Internet socket of type SOCK_RAW
. The
ICMPv6 message protocol is accessible from a raw socket.
A number of variables are implemented in the net.inet6 branch of the sysctl(3) MIB. In addition to the variables supported by the transport protocols (for which the respective manual pages may be consulted), the following general variables are defined:
IPV6CTL_FORWARDING
IPV6CTL_SENDREDIRECTS
IPV6CTL_DEFHLIM
IPV6CTL_MAXFRAGPACKETS
IPV6CTL_ACCEPT_RTADV
IPV6CTL_LOG_INTERVAL
IPV6CTL_HDRNESTLIMIT
IPV6CTL_DAD_COUNT
IPV6CTL_AUTO_FLOWLABEL
IPV6CTL_DEFMCASTHLIM
IPV6CTL_GIF_HLIM
IPV6CTL_KAME_VERSION
IPV6CTL_USE_DEPRECATED
IPV6CTL_RR_PRUNE
IPV6CTL_MAPPED_ADDR
AF_INET6
sockets. Defaults to on.IPV6CTL_RTEXPIRE
IPV6CTL_RTMINEXPIRE
IPV6CTL_RTMAXCACHE
The behavior of AF_INET6
TCP/UDP socket is
documented in RFC2553. Basically, it says this:
AF_INET6
socket
(bind(2) with an address specified)
should accept IPv6 traffic to that address only.AF_INET6
socket (bind(2) to IPv6 address
::
), and there is no wildcard bind
AF_INET
socket on that TCP/UDP port, IPv6 traffic
as well as IPv4 traffic should be routed to that
AF_INET6
socket. IPv4 traffic should be seen as if
it came from an IPv6 address like ::ffff:10.1.1.1
.
This is called an IPv4 mapped address.AF_INET
socket
and a wildcard bind AF_INET6
socket on one TCP/UDP
port, they should behave separately. IPv4 traffic should be routed to the
AF_INET
socket and IPv6 should be routed to the
AF_INET6
socket.However, RFC2553 does not define the ordering constraint between
calls to bind(2), nor how IPv4 TCP/UDP
port numbers and IPv6 TCP/UDP port numbers relate to each other (should they
be integrated or separated). Implemented behavior is very different from
kernel to kernel. Therefore, it is unwise to rely too much upon the behavior
of AF_INET6
wildcard bind sockets. It is recommended
to listen to two sockets, one for AF_INET
and
another for AF_INET6
, when you would like to accept
both IPv4 and IPv6 traffic.
It should also be noted that malicious parties can take advantage
of the complexity presented above, and are able to bypass access control, if
the target node routes IPv4 traffic to AF_INET6
socket. Users are advised to take care handling connections from IPv4 mapped
address to AF_INET6
sockets.
ioctl(2), socket(2), sysctl(3), icmp6(4), intro(4), ip6(4), tcp(4), udp(4)
Tatsuya Jinmei and Atsushi Onoe, An Extension of Format for IPv6 Scoped Addresses, internet draft, draft-ietf-ipngwg-scopedaddr-format-02.txt, June 2000, work in progress material.
The inet6
protocol interfaces are defined
in RFC2553 and RFC2292. The implementation described herein appeared in the
WIDE/KAME project.
The IPv6 support is subject to change as the Internet protocols develop. Users should not depend on details of the current implementation, but rather the services exported.
Users are suggested to implement “version
independent” code as much as possible, as you will need to support
both inet(4) and
inet6
.
January 29, 1999 | macOS 15.0 |