|AUDIT_EVENT(5)||File Formats Manual||AUDIT_EVENT(5)|
audit event descriptions
The audit(4) subsystem has been deprecated since macOS 11.0, disabled since macOS 14.0, and WILL BE REMOVED in a future version of macOS. Applications that require a security event stream should use the EndpointSecurity(7) API instead.
On this version of macOS, you can re-enable audit(4) by renaming or copying /etc/security/audit_control.example to /etc/security/audit_control, re-enabling the system/com.apple.auditd service by running launchctl enable system/com.apple.auditd as root, and rebooting.
audit_event file contains descriptions
of the auditable events on the system. Each line maps an audit event number
to a name, a description, and a class. Entries are of the form:
Each eventclass should have a corresponding entry in the audit_class(5) file.
Example entries in this file are:
0:AUE_NULL:indir system call:no 1:AUE_EXIT:exit(2):pc 2:AUE_FORK:fork(2):pc 3:AUE_OPEN:open(2):fa
The OpenBSM implementation was created by McAfee Research, the security division of McAfee Inc., under contract to Apple Computer Inc. in 2004. It was subsequently adopted by the TrustedBSD Project as the foundation for the OpenBSM distribution.
This software was created by McAfee Research, the security research division of McAfee, Inc., under contract to Apple Computer Inc. Additional authors include Wayne Salamon, Robert Watson, and SPARTA Inc.
The Basic Security Module (BSM) interface to audit records and audit event stream format were defined by Sun Microsystems.
|January 24, 2004||macOS 14.1|