|AUDIT_CLASS(5)||File Formats Manual||AUDIT_CLASS(5)|
audit event class descriptions
The audit(4) subsystem has been deprecated since macOS 11.0, disabled since macOS 14.0, and WILL BE REMOVED in a future version of macOS. Applications that require a security event stream should use the EndpointSecurity(7) API instead.
On this version of macOS, you can re-enable audit(4) by renaming or copying /etc/security/audit_control.example to /etc/security/audit_control, re-enabling the system/com.apple.auditd service by running launchctl enable system/com.apple.auditd as root, and rebooting.
audit_class file contains descriptions
of the auditable event classes on the system. Each auditable event is a
member of an event class. Each line maps an audit event mask (bitmap) to a
class and a description. Entries are of the form:
Example entries in this file are:
0x00000000:no:invalid class 0x00000001:fr:file read 0x00000002:fw:file write 0x00000004:fa:file attribute access 0x00000080:pc:process 0x10000000:res:reserved for internal use 0xffffffff:all:all flags set
The audit class res is reserved for internal use. Unentitled applications can still modify the event class preselection mask for an audit event (for example by using the audit_event(5) configuration file or the auditon(2) system call with the A_SETCLASS command), however these applications will not be able to change the res audit class mask for that event.
The OpenBSM implementation was created by McAfee Research, the security division of McAfee Inc., under contract to Apple Computer Inc. in 2004. It was subsequently adopted by the TrustedBSD Project as the foundation for the OpenBSM distribution.
This software was created by McAfee Research, the security research division of McAfee, Inc., under contract to Apple Computer Inc. Additional authors include Wayne Salamon, Robert Watson, and SPARTA Inc.
The Basic Security Module (BSM) interface to audit records and audit event stream format were defined by Sun Microsystems.
|January 24, 2004||macOS 14.1|