STORE(9) Kernel Developer's Manual STORE(9)

store, subyte, suibyte, suiword, sulong, suulong, suwordstore data to user-space

#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>
#include <sys/resourcevar.h>

int
subyte(user_addr_t addr, int byte);

int
suibyte(user_addr_t addr, int byte);

int
suiword(user_addr_t addr, int word);

int
sulong(user_addr_t addr, int64_t longword);

int
suulong(user_addr_t addr, uint64_t longword);

int
suword(user_addr_t addr, int word);

The store functions are designed to copy small amounts of data to user-space.

The store routines provide the following functionality:

()
Stores a byte of data to the user-space address addr.
()
Stores a byte of data to the user-space address addr. This function is safe to call during an interrupt context.
()
Stores a word of data to the user-space address addr. This function is safe to call during an interrupt context.
()
Stores a long word of data to the user-space address addr.
()
Stores a unsigned long word of data to the user-space address addr.
()
Stores a word of data to the user-space address addr.

The store functions return 0 on success or -1 on failure.

copy(9), fetch(9)

December 16, 2004 macOS 14.5