|STICKY(7)||Miscellaneous Information Manual||STICKY(7)|
sticky — sticky
text and append-only directories
A special file mode, called the
bit (mode S_ISVTX), is used to indicate special treatment for
directories. It is ignored for regular files. See
chmod(2) or the file
<sys/stat.h> for an
explanation of file modes.
A directory whose `sticky bit' is set becomes an append-only directory, or, more accurately, a directory in which the deletion of files is restricted. A file in a sticky directory may only be removed or renamed by a user if the user has write permission for the directory and the user is the owner of the file, the owner of the directory, or the super-user. This feature is usefully applied to directories such as /tmp which must be publicly writable but should deny users the license to arbitrarily delete or rename each others' files.
Any user may create a sticky directory. See chmod(1) for details about modifying file modes.
sticky command appeared in
Version 7 AT&T UNIX/32V.
|June 5, 1993||macOS 14.1|