|UTMPX(5)||File Formats Manual||UTMPX(5)|
utmpx — user
In contrast to utmp and wtmp, the extended databases in utmpx and wtmpx reserve more space for logging hostnames, and also information on a process' ID, termination signal and exit status.
The ⟨utmpx.h⟩ header defines
the structures and functions for logging user. Currently logged in users are
tracked in /var/run/utmpx. The interface to the
utmpx file is described in
endutxent(3). The file is not
automatically created if they do not exist; it must be created manually.
Traditionally, separate files would be used to store the running
log of the logins and logouts (wtmpx), and the last
login of each user (lastlogx). With the availability
of the Apple system log facility asl(3),
these separate files can be replace with log entries, which are
automatically generated when
utmpx entries are
written. The API to access the logins and logouts is described in
endutxent_wtmp(3) while the
last login info is accessible with
For compatibility, changes to
reflected in utmp(3) (in the
utmp, wtmp and
lastlog files), but not the other way around.
|January 31, 2007||macOS 14.1|