|SYSCTL.CONF(5)||File Formats Manual||SYSCTL.CONF(5)|
kernel state defaults
The /etc/sysctl.conf file is read in when the system goes into multi-user mode to set default settings for the kernel. The /etc/sysctl.conf is in the format of the sysctl(8) command, i.e.
Comments are denoted by a “#” at the beginning of a line.
To disable coredumps, you may use a configuration like:
# Disable coredumps. kern.coredump=0
sysctl.conf file appeared in
If loadable kernel modules are used to introduce additional kernel
functionality and sysctls to manage that functionality,
sysctl.conf may be processed too early in the boot
process to set those sysctls.
|August 3, 2007||macOS 14.1|