SUDOERS(5) | File Formats Manual | SUDOERS(5) |
sudoers - default sudo security policy plugin
The sudoers policy plugin determines a user's sudo privileges. It is the default sudo policy plugin. The policy is driven by the /private/etc/sudoers file or, optionally, in LDAP. The policy format is described in detail in the SUDOERS FILE FORMAT section. For information on storing sudoers policy information in LDAP, see sudoers.ldap(5).
sudo consults the sudo.conf(5) file to determine which plugins to load. If no sudo.conf(5) file is present, or if it contains no Plugin lines, sudoers will be used for auditing, policy decisions and I/O logging. To explicitly configure sudo.conf(5) to use the sudoers plugin, the following configuration can be used.
Plugin sudoers_audit sudoers.so Plugin sudoers_policy sudoers.so Plugin sudoers_io sudoers.so
Starting with sudo 1.8.5, it is possible to specify optional arguments to the sudoers plugin in the sudo.conf(5) file. Plugin arguments, if any, should be listed after the path to the plugin (i.e., after sudoers.so). The arguments are only effective for the plugin that opens (and parses) the sudoers file.
For sudo version 1.9.1 and higher, this is the sudoers_audit plugin. For older versions, it is the sudoers_policy plugin. Multiple arguments may be specified, separated by white space. For example:
Plugin sudoers_audit sudoers.so sudoers_mode=0400 error_recovery=false
The following plugin arguments are supported:
For more information on configuring sudo.conf(5), refer to its manual.
The sudoers security policy requires that most users authenticate themselves before they can use sudo. A password is not required if the invoking user is root, if the target user is the same as the invoking user, or if the policy has disabled authentication for the user or command. Unlike su(1), when sudoers requires authentication, it validates the invoking user's credentials, not the target user's (or root's) credentials. This can be changed via the rootpw, targetpw and runaspw flags, described later.
If a user who is not listed in the policy tries to run a command via sudo, mail is sent to the proper authorities. The address used for such mail is configurable via the mailto Defaults entry (described later) and defaults to root.
No mail will be sent if an unauthorized user tries to run sudo with the -l or -v option unless there is an authentication error and either the mail_always or mail_badpass flags are enabled. This allows users to determine for themselves whether or not they are allowed to use sudo. By default, all attempts to run sudo (successful or not) are logged, regardless of whether or not mail is sent.
If sudo is run by root and the SUDO_USER environment variable is set, the sudoers policy will use this value to determine who the actual user is. This can be used by a user to log commands through sudo even when a root shell has been invoked. It also allows the -e option to remain useful even when invoked via a sudo-run script or program. Note, however, that the sudoers file lookup is still done for root, not the user specified by SUDO_USER.
sudoers uses per-user time stamp files for credential caching. Once a user has been authenticated, a record is written containing the user-ID that was used to authenticate, the terminal session ID, the start time of the session leader (or parent process) and a time stamp (using a monotonic clock if one is available). The user may then use sudo without a password for a short period of time (5 minutes unless overridden by the timestamp_timeout option). By default, sudoers uses a separate record for each terminal, which means that a user's login sessions are authenticated separately. The timestamp_type option can be used to select the type of time stamp record sudoers will use.
By default, sudoers logs both successful and unsuccessful attempts (as well as errors). The log_allowed and log_denied flags can be used to control this behavior. Messages can be logged to syslog(3), a log file, or both. The default is to log to syslog(3) but this is configurable via the syslog and logfile settings. See EVENT LOGGING for a description of the log file format.
sudoers is also capable of running a command in a pseudo-terminal and logging input and/or output. The standard input, standard output, and standard error can be logged even when not associated with a terminal. For more information about I/O logging, see the I/O LOGGING section.
Starting with version 1.9, the log_servers setting may be used to send event and I/O log data to a remote server running sudo_logsrvd or another service that implements the protocol described by sudo_logsrv.proto(5).
Since environment variables can influence program behavior, sudoers provides a means to restrict which variables from the user's environment are inherited by the command to be run. There are two distinct ways sudoers can deal with environment variables.
By default, the env_reset flag is enabled. This causes commands to be executed with a new, minimal environment. On AIX (and Linux systems without PAM), the environment is initialized with the contents of the /etc/environment file. The HOME, MAIL, SHELL, LOGNAME and USER environment variables are initialized based on the target user and the SUDO_* variables are set based on the invoking user. Additional variables, such as DISPLAY, PATH and TERM, are preserved from the invoking user's environment if permitted by the env_check, or env_keep options. A few environment variables are treated specially. If the PATH and TERM variables are not preserved from the user's environment, they will be set to default values. The LOGNAME and USER are handled as a single entity. If one of them is preserved (or removed) from the user's environment, the other will be as well. If LOGNAME and USER are to be preserved but only one of them is present in the user's environment, the other will be set to the same value. This avoids an inconsistent environment where one of the variables describing the user name is set to the invoking user and one is set to the target user. Environment variables with a value beginning with ‘()’ are removed unless both the name and value parts are matched by env_keep or env_check, as they may be interpreted as functions by the bash shell. Prior to version 1.8.11, such variables were always removed.
If, however, the env_reset flag is disabled, any variables not explicitly denied by the env_check and env_delete options are allowed and their values are inherited from the invoking process. Prior to version 1.8.21, environment variables with a value beginning with ‘()’ were always removed. Beginning with version 1.8.21, a pattern in env_delete is used to match bash shell functions instead. Since it is not possible to block all potentially dangerous environment variables, use of the default env_reset behavior is encouraged.
Environment variables specified by env_check, env_delete, or env_keep may include one or more ‘*’ characters which will match zero or more characters. No other wildcard characters are supported.
By default, environment variables are matched by name. However, if the pattern includes an equal sign (‘=’), both the variables name and value must match. For example, a bash shell function could be matched as follows:
env_keep += "BASH_FUNC_my_func%%=()*"
Without the ‘=()*’ suffix, this would not match, as bash shell functions are not preserved by default.
The complete list of environment variables that are preserved or removed, as modified by global Defaults parameters in sudoers, is displayed when sudo is run by root with the -V option. The list of environment variables to remove varies based on the operating system sudo is running on.
Other sudoers options may influence the command environment, such as always_set_home, secure_path, set_logname, and set_home.
On systems that support PAM where the pam_env module is enabled for sudo, variables in the PAM environment may be merged in to the environment. If a variable in the PAM environment is already present in the user's environment, the value will only be overridden if the variable was not preserved by sudoers. When env_reset is enabled, variables preserved from the invoking user's environment by the env_keep list take precedence over those in the PAM environment. When env_reset is disabled, variables present the invoking user's environment take precedence over those in the PAM environment unless they match a pattern in the env_delete list.
The dynamic linker on most operating systems will remove variables that can control dynamic linking from the environment of set-user-ID executables, including sudo. Depending on the operating system this may include _RLD*, DYLD_*, LD_*, LDR_*, LIBPATH, SHLIB_PATH, and others. These type of variables are removed from the environment before sudo even begins execution and, as such, it is not possible for sudo to preserve them.
As a special case, if the -i option (initial login) is specified, sudoers will initialize the environment regardless of the value of env_reset. The DISPLAY, PATH and TERM variables remain unchanged; HOME, MAIL, SHELL, USER, and LOGNAME are set based on the target user. On AIX (and Linux systems without PAM), the contents of /etc/environment are also included. All other environment variables are removed unless permitted by env_keep or env_check, described above.
Finally, the restricted_env_file and env_file files are applied, if present. The variables in restricted_env_file are applied first and are subject to the same restrictions as the invoking user's environment, as detailed above. The variables in env_file are applied last and are not subject to these restrictions. In both cases, variables present in the files will only be set to their specified values if they would not conflict with an existing environment variable.
The sudoers file is composed of two types of entries: aliases (basically variables) and user specifications (which specify who may run what).
When multiple entries match for a user, they are applied in order. Where there are multiple matches, the last match is used (which is not necessarily the most specific match).
The sudoers file grammar will be described below in Extended Backus-Naur Form (EBNF). Don't despair if you are unfamiliar with EBNF; it is fairly simple, and the definitions below are annotated.
By default, sudoers uses the operating system's native method of setting resource limits for the target user. On Linux systems, resource limits are usually set by the pam_limits.so PAM module. On some BSD systems, the /etc/login.conf file specifies resource limits for the user. On AIX systems, resource limits are configured in the /etc/security/limits file. If there is no system mechanism to set per-user resource limits, the command will run with the same limits as the invoking user. The one exception to this is the core dump file size, which is set by sudoers to 0 by default. Disabling core dumps by default makes it possible to avoid potential security problems where the core file is treated as trusted input.
Resource limits may also be set in the sudoers file itself, in which case they override those set by the system. See the rlimit_as, rlimit_core, rlimit_cpu, rlimit_data, rlimit_fsize, rlimit_locks, rlimit_memlock, rlimit_nofile, rlimit_nproc, rlimit_rss, rlimit_stack options described below. Resource limits in sudoers may be specified in one of the following formats:
For example, to restore the historic core dump file size behavior, a line like the following may be used.
Resource limits in sudoers are only supported by version 1.8.7 or higher.
EBNF is a concise and exact way of describing the grammar of a language. Each EBNF definition is made up of production rules. For example:
symbol ::= definition | alternate1 | alternate2 ...
Each production rule references others and thus makes up a grammar for the language. EBNF also contains the following operators, which many readers will recognize from regular expressions. Do not, however, confuse them with “wildcard” characters, which have different meanings.
Parentheses may be used to group symbols together. For clarity, we will use single quotes ('') to designate what is a verbatim character string (as opposed to a symbol name).
There are four kinds of aliases: User_Alias, Runas_Alias, Host_Alias and Cmnd_Alias. Beginning with sudo 1.9.0, Cmd_Alias may be used in place of Cmnd_Alias if desired.
Alias ::= 'User_Alias' User_Alias_Spec (':' User_Alias_Spec)* | 'Runas_Alias' Runas_Alias_Spec (':' Runas_Alias_Spec)* | 'Host_Alias' Host_Alias_Spec (':' Host_Alias_Spec)* | 'Cmnd_Alias' Cmnd_Alias_Spec (':' Cmnd_Alias_Spec)* | 'Cmd_Alias' Cmnd_Alias_Spec (':' Cmnd_Alias_Spec)* User_Alias ::= NAME User_Alias_Spec ::= User_Alias '=' User_List Runas_Alias ::= NAME Runas_Alias_Spec ::= Runas_Alias '=' Runas_List Host_Alias ::= NAME Host_Alias_Spec ::= Host_Alias '=' Host_List Cmnd_Alias ::= NAME Cmnd_Alias_Spec ::= Cmnd_Alias '=' Cmnd_List NAME ::= [A-Z]([A-Z][0-9]_)*
Each alias definition is of the form
Alias_Type NAME = item1, item2, ...
where Alias_Type is one of User_Alias, Runas_Alias, Host_Alias, or Cmnd_Alias. A NAME is a string of uppercase letters, numbers, and underscore characters (‘_’). A NAME must start with an uppercase letter. It is possible to put several alias definitions of the same type on a single line, joined by a colon (‘:’). For example:
Alias_Type NAME = item1, item2, item3 : NAME = item4, item5
It is a syntax error to redefine an existing alias. It is possible to use the same name for aliases of different types, but this is not recommended.
The definitions of what constitutes a valid alias member follow.
User_List ::= User | User ',' User_List User ::= '!'* user name | '!'* #user-ID | '!'* %group | '!'* %#group-ID | '!'* +netgroup | '!'* %:nonunix_group | '!'* %:#nonunix_gid | '!'* User_Alias
A User_List is made up of one or more user names, user-IDs (prefixed with ‘#’), system group names and IDs (prefixed with ‘%’ and ‘%#’ respectively), netgroups (prefixed with ‘+’), non-Unix group names and IDs (prefixed with ‘%:’ and ‘%:#’ respectively), and User_Aliases. Each list item may be prefixed with zero or more ‘!’ operators. An odd number of ‘!’ operators negate the value of the item; an even number just cancel each other out. User netgroups are matched using the user and domain members only; the host member is not used when matching.
A user name, user-ID, group, group-ID, netgroup, nonunix_group or nonunix_gid may be enclosed in double quotes to avoid the need for escaping special characters. Alternately, special characters may be specified in escaped hex mode, e.g., \x20 for space. When using double quotes, any prefix characters must be included inside the quotes.
The actual nonunix_group and nonunix_gid syntax depends on the underlying group provider plugin. For instance, the QAS AD plugin supports the following formats:
See GROUP PROVIDER PLUGINS for more information.
Quotes around group names are optional. Unquoted strings must use a backslash (‘\’) to escape spaces and special characters. See Other special characters and reserved words for a list of characters that need to be escaped.
Runas_List ::= Runas_Member | Runas_Member ',' Runas_List Runas_Member ::= '!'* user name | '!'* #user-ID | '!'* %group | '!'* %#group-ID | '!'* %:nonunix_group | '!'* %:#nonunix_gid | '!'* +netgroup | '!'* Runas_Alias | '!'* ALL
A Runas_List is similar to a User_List except that instead of User_Aliases it can contain Runas_Aliases. User names and groups are matched as strings. In other words, two users (groups) with the same user (group) ID are considered to be distinct. If you wish to match all user names with the same user-ID (e.g., root and toor), you can use a user-ID instead of a name (#0 in the example given). The user-ID or group-ID specified in a Runas_Member need not be listed in the password or group database.
Host_List ::= Host | Host ',' Host_List Host ::= '!'* host name | '!'* ip_addr | '!'* network(/netmask)? | '!'* +netgroup | '!'* Host_Alias | '!'* ALL
A Host_List is made up of one or more host names, IP addresses, network numbers, netgroups (prefixed with ‘+’), and other aliases. Again, the value of an item may be negated with the ‘!’ operator. Host netgroups are matched using the host (both qualified and unqualified) and domain members only; the user member is not used when matching. If you specify a network number without a netmask, sudo will query each of the local host's network interfaces and, if the network number corresponds to one of the hosts's network interfaces, will use the netmask of that interface. The netmask may be specified either in standard IP address notation (e.g., 255.255.255.0 or ffff:ffff:ffff:ffff::), or CIDR notation (number of bits, e.g., 24 or 64). A host name may include shell-style wildcards (see the Wildcards section below), but unless the hostname command on your machine returns the fully qualified host name, you'll need to use the fqdn flag for wildcards to be useful. sudo only inspects actual network interfaces; this means that IP address 127.0.0.1 (localhost) will never match. Also, the host name “localhost” will only match if that is the actual host name, which is usually only the case for non-networked systems.
digest ::= [A-Fa-f0-9]+ | [A-Za-z0-9\+/=]+ Digest_Spec ::= "sha224" ':' digest | "sha256" ':' digest | "sha384" ':' digest | "sha512" ':' digest Digest_List ::= Digest_Spec | Digest_Spec ',' Digest_List Cmnd_List ::= Cmnd | Cmnd ',' Cmnd_List command name ::= regex | file name command ::= command name | command name args | command name regex | command name '""' | ALL Edit_Spec ::= "sudoedit" file name+ | "sudoedit" regex | "sudoedit" List_Spec ::= "list" Cmnd ::= Digest_List? '!'* command | '!'* directory | '!'* Edit_Spec | '!'* List_Spec | '!'* Cmnd_Alias
A Cmnd_List is a list of one or more commands, directories, or aliases. A command is a fully qualified file name, which may include shell-style wildcards (see the Wildcards section below), or a regular expression that starts with ‘^’ and ends with ‘$’ (see the Regular expressions section below). A directory is a fully qualified path name ending in a ‘/’. When you specify a directory in a Cmnd_List, the user will be able to run any file within that directory (but not in any sub-directories therein). If no command line arguments are specified, the user may run the command with any arguments they choose. Command line arguments can include wildcards or be a regular expression that starts with ‘^’ and ends with ‘$’. If the command line arguments consist of ‘""’, the command may only be run with no arguments.
If a Cmnd has associated command line arguments, the arguments in the Cmnd must match those given by the user on the command line. If the arguments in a Cmnd begin with the ‘^’ character, they will be interpreted as a regular expression and matched accordingly. Otherwise, shell-style wildcards are used when matching. Unless a regular expression is specified, the following characters must be escaped with a ‘\’ if they are used in command arguments: ‘,’, ‘:’, ‘=’, ‘\’. To prevent arguments in a Cmnd that begin with a ‘^’ character from being interpreted as a regular expression, the ‘^’ must be escaped with a ‘\’.
There are two commands built into sudo itself: “list” and “sudoedit”. Unlike other commands, these two must be specified in the sudoers file without a leading path.
The “list” built-in can be used to permit a user to list another user's privileges with sudo's -U option. For example, “sudo -l -U otheruser”. A user with the “list” privilege is able to list another user's privileges even if they don't have permission to run commands as that user. By default, only root or a user with the ability to run any command as either root or the specified user on the current host may use the -U option. No command line arguments may be specified with the “list” built-in.
The “sudoedit” built-in is used to permit a user to run sudo with the -e option (or as sudoedit). It may take command line arguments just as a normal command does. Unlike other commands, “sudoedit” is built into sudo itself and must be specified in the sudoers file without a leading path. If a leading path is present, for example /usr/bin/sudoedit, the path name will be silently converted to “sudoedit”. A fully-qualified path for sudoedit is treated as an error by visudo.
A command may be preceded by a Digest_List, a comma-separated list of one or more Digest_Spec entries. If a Digest_List is present, the command will only match successfully if it can be verified using one of the SHA-2 digests in the list. Starting with version 1.9.0, the ALL reserved word can be used in conjunction with a Digest_List. The following digest formats are supported: sha224, sha256, sha384, and sha512. The string may be specified in either hex or base64 format (base64 is more compact). There are several utilities capable of generating SHA-2 digests in hex format such as openssl, shasum, sha224sum, sha256sum, sha384sum, sha512sum.
For example, using openssl:
$ openssl dgst -sha224 /bin/ls SHA224(/bin/ls)= 118187da8364d490b4a7debbf483004e8f3e053ec954309de2c41a25
It is also possible to use openssl to generate base64 output:
$ openssl dgst -binary -sha224 /bin/ls | openssl base64 EYGH2oNk1JC0p9679IMATo8+BT7JVDCd4sQaJQ==
Warning, if the user has write access to the command itself (directly or via a sudo command), it may be possible for the user to replace the command after the digest check has been performed but before the command is executed. A similar race condition exists on systems that lack the fexecve(2) system call when the directory in which the command is located is writable by the user. See the description of the fdexec setting for more information on how sudo executes commands that have an associated digest.
Command digests are only supported by version 1.8.7 or higher.
Certain configuration options may be changed from their default values at run-time via one or more Default_Entry lines. These may affect all users on any host, all users on a specific host, a specific user, a specific command, or commands being run as a specific user. Per-command entries may not include command line arguments. If you need to specify arguments, define a Cmnd_Alias and reference that instead.
Default_Type ::= 'Defaults' | 'Defaults' '@' Host_List | 'Defaults' ':' User_List | 'Defaults' '!' Cmnd_List | 'Defaults' '>' Runas_List Default_Entry ::= Default_Type Parameter_List Parameter_List ::= Parameter | Parameter ',' Parameter_List Parameter ::= Parameter '=' Value | Parameter '+=' Value | Parameter '-=' Value | '!'* Parameter
Parameters may be flags, integer values, strings, or lists. Flags are implicitly boolean and can be turned off via the ‘!’ operator. Some integer, string and list parameters may also be used in a boolean context to disable them. Values may be enclosed in double quotes ("") when they contain multiple words. Special characters may be escaped with a backslash (‘\’).
To include a literal backslash character in a command line argument you must escape the backslash twice. For example, to match ‘\n’ as part of a command line argument, you must use ‘\\\\n’ in the sudoers file. This is due to there being two levels of escaping, one in the sudoers parser itself and another when command line arguments are matched by the fnmatch(3) or regexec(3) function.
Lists have two additional assignment operators, ‘+=’ and ‘-=’. These operators are used to add to and delete from a list respectively. It is not an error to use the ‘-=’ operator to remove an element that does not exist in a list.
Defaults entries are parsed in the following order: global, host, user, and runas Defaults first, then command defaults. If there are multiple Defaults settings of the same type, the last matching setting is used. The following Defaults settings are parsed before all others since they may affect subsequent entries: fqdn, group_plugin, runas_default, sudoers_locale.
See SUDOERS OPTIONS for a list of supported Defaults parameters.
User_Spec ::= User_List Host_List '=' Cmnd_Spec_List \ (':' Host_List '=' Cmnd_Spec_List)* Cmnd_Spec_List ::= Cmnd_Spec | Cmnd_Spec ',' Cmnd_Spec_List Cmnd_Spec ::= Runas_Spec? Option_Spec* (Tag_Spec ':')* Cmnd Runas_Spec ::= '(' Runas_List? (':' Runas_List)? ')' Option_Spec ::= (Date_Spec | Timeout_Spec) AppArmor_Spec ::= 'APPARMOR_PROFILE=profile' Date_Spec ::= ('NOTBEFORE=timestamp' | 'NOTAFTER=timestamp') Timeout_Spec ::= 'TIMEOUT=timeout' Chdir_Spec ::= 'CWD=directory' Chroot_Spec ::= 'CHROOT=directory' Tag_Spec ::= ('EXEC' | 'NOEXEC' | 'FOLLOW' | 'NOFOLLOW' | 'LOG_INPUT' | 'NOLOG_INPUT' | 'LOG_OUTPUT' | 'NOLOG_OUTPUT' | 'MAIL' | 'NOMAIL' | 'INTERCEPT' | 'NOINTERCEPT' | 'PASSWD' | 'NOPASSWD' | 'SETENV' | 'NOSETENV')
A user specification determines which commands a user may run (and as what user) on specified hosts. By default, commands are run as root (unless runas_default has been set to a different value) but this can also be changed on a per-command basis.
The basic structure of a user specification is “who where = (as_whom) what”. Let's break that down into its constituent parts:
A Runas_Spec determines the user and/or the group that a command may be run as. A fully-specified Runas_Spec consists of two Runas_Lists (as defined above) separated by a colon (‘:’) and enclosed in a set of parentheses. The first Runas_List indicates which users the command may be run as via the -u option. The second defines a list of groups that may be specified via the -g option (in addition to any of the target user's groups). If both Runas_Lists are specified, the command may be run with any combination of users and groups listed in their respective Runas_Lists. If only the first is specified, the command may be run as any user in the list and, optionally, with any group the target user belongs to. If the first Runas_List is empty but the second is specified, the command may be run as the invoking user with the group set to any listed in the Runas_List. If both Runas_Lists are empty, the command may only be run as the invoking user and the group, if specified, must be one that the invoking user is a member of. If no Runas_Spec is specified, the command may only be run as the runas_default user (root by default) and the group, if specified, must be one that the runas_default user is a member of.
A Runas_Spec sets the default for the commands that follow it. What this means is that for the entry:
dgb boulder = (operator) /bin/ls, /bin/kill, /usr/bin/lprm
The user dgb may run /bin/ls, /bin/kill, and /usr/bin/lprm on the host boulder—but only as operator. For example:
$ sudo -u operator /bin/ls
It is also possible to override a Runas_Spec later on in an entry. If we modify the entry like so:
dgb boulder = (operator) /bin/ls, (root) /bin/kill, /usr/bin/lprm
Then user dgb is now allowed to run /bin/ls as operator, but /bin/kill and /usr/bin/lprm as root.
We can extend this to allow dgb to run /bin/ls with either the user or group set to operator:
dgb boulder = (operator : operator) /bin/ls, (root) /bin/kill,\ /usr/bin/lprm
While the group portion of the Runas_Spec permits the user to run as command with that group, it does not force the user to do so. If no group is specified on the command line, the command will run with the group listed in the target user's password database entry. The following would all be permitted by the sudoers entry above:
$ sudo -u operator /bin/ls $ sudo -u operator -g operator /bin/ls $ sudo -g operator /bin/ls
In the following example, user tcm may run commands that access a modem device file with the dialer group.
tcm boulder = (:dialer) /usr/bin/tip, /usr/bin/cu,\ /usr/local/bin/minicom
In this example only the group will be set, the command still runs as user tcm. For example:
$ sudo -g dialer /usr/bin/cu
Multiple users and groups may be present in a Runas_Spec, in which case the user may select any combination of users and groups via the -u and -g options. In this example:
alan ALL = (root, bin : operator, system) ALL
user alan may run any command as either user root or bin, optionally setting the group to operator or system.
A Cmnd may have zero or more options associated with it. Options may consist of AppArmor profiles, start and/or end dates and command timeouts. Once an option is set for a Cmnd, subsequent Cmnds in the Cmnd_Spec_List, inherit that option unless it is overridden by another option. Option names are reserved words in sudoers. This means that none of the valid option names (see below) can be used when declaring an alias.
On systems supporting AppArmor, sudoers file entries may optionally specify an AppArmor profile that should be used to confine a command. If an AppArmor profile is specified with the command, it will override any default values specified in sudoers. Appropriate profile transition rules must be defined to support the profile change specified for a user.
AppArmor profiles can be specified in any way that complies with the rules of aa_change_profile(2). For instance, in the following sudoers entry
alice ALL = (root) APPARMOR_PROFILE=my-profile ALL
the user alice may run any command as root under confinement by the profile ‘my-profile’. You can also stack profiles, or allow a user to run commands unconfined by any profile. For example:
bob ALL = (root) APPARMOR_PROFILE=foo//&bar /usr/bin/vi cathy ALL = (root) APPARMOR_PROFILE=unconfined /bin/ls
These sudoers entries allow user bob to run /usr/bin/vi as root under the stacked profiles ‘foo’ and ‘bar’, and user cathy to run /bin/ls without any confinement at all.
sudoers rules can be specified with a start and end date via the NOTBEFORE and NOTAFTER settings. The time stamp must be specified in “Generalized Time” as defined by RFC 4517. The format is effectively ‘yyyymmddHHMMSSZ’ where the minutes and seconds are optional. The ‘Z’ suffix indicates that the time stamp is in Coordinated Universal Time (UTC). It is also possible to specify a timezone offset from UTC in hours and minutes instead of a ‘Z’. For example, ‘-0500’ would correspond to Eastern Standard time in the US. As an extension, if no ‘Z’ or timezone offset is specified, local time will be used.
The following are all valid time stamps:
20170214083000Z 2017021408Z 20160315220000-0500 20151201235900
A command may have a timeout associated with it. If the timeout expires before the command has exited, the command will be terminated. The timeout may be specified in combinations of days, hours, minutes, and seconds with a single-letter case-insensitive suffix that indicates the unit of time. For example, a timeout of 7 days, 8 hours, 30 minutes, and 10 seconds would be written as ‘7d8h30m10s’. If a number is specified without a unit, seconds are assumed. Any of the days, minutes, hours, or seconds may be omitted. The order must be from largest to smallest unit and a unit may not be specified more than once.
The following are all valid timeout values: ‘7d8h30m10s’, ‘14d’, ‘8h30m’, ‘600s’, ‘3600’. The following are invalid timeout values: ‘12m2w1d’, ‘30s10m4h’, ‘1d2d3h’.
This setting is only supported by version 1.8.20 or higher.
The working directory that the command will be run in can be specified using the CWD setting. The directory must be a fully-qualified path name beginning with a ‘/’ or ‘~’ character, or the special value “*”. A value of “*” indicates that the user may specify the working directory by running sudo with the -D option. By default, commands are run from the invoking user's current working directory, unless the -i option is given. Path names of the form ~user/path/name are interpreted as being relative to the named user's home directory. If the user name is omitted, the path will be relative to the runas user's home directory.
This setting is only supported by version 1.9.3 or higher.
The root directory that the command will be run in can be specified using the CHROOT setting. The directory must be a fully-qualified path name beginning with a ‘/’ or ‘~’ character, or the special value “*”. A value of “*” indicates that the user may specify the root directory by running sudo with the -R option. This setting can be used to run the command in a chroot(2) “sandbox” similar to the chroot(8) utility. Path names of the form ~user/path/name are interpreted as being relative to the named user's home directory. If the user name is omitted, the path will be relative to the runas user's home directory.
This setting is only supported by version 1.9.3 or higher.
A command may have zero or more tags associated with it. The following tag values are supported: EXEC, NOEXEC, FOLLOW, NOFOLLOW, LOG_INPUT, NOLOG_INPUT, LOG_OUTPUT, NOLOG_OUTPUT, MAIL, NOMAIL, INTERCEPT, NOINTERCEPT, PASSWD, NOPASSWD, SETENV, and NOSETENV. Once a tag is set on a Cmnd, subsequent Cmnds in the Cmnd_Spec_List, inherit the tag unless it is overridden by the opposite tag (in other words, PASSWD overrides NOPASSWD and NOEXEC overrides EXEC).
If sudo has been compiled with noexec support and the underlying operating system supports it, the NOEXEC tag can be used to prevent a dynamically-linked executable from running further commands itself.
In the following example, user aaron may run /usr/bin/more and /usr/bin/vi but shell escapes will be disabled.
aaron shanty = NOEXEC: /usr/bin/more, /usr/bin/vi
See the Preventing shell escapes section below for more details on how NOEXEC works and whether or not it will work on your system.
Starting with version 1.8.15, sudoedit will not open a file that is a symbolic link unless the sudoedit_follow flag is enabled. The FOLLOW and NOFOLLOW tags override the value of sudoedit_follow and can be used to permit (or deny) the editing of symbolic links on a per-command basis. These tags are only effective for the sudoedit command and are ignored for all other commands.
These tags override the value of the log_input flag on a per-command basis. For more information, see I/O LOGGING.
These tags override the value of the log_output flag on a per-command basis. For more information, see I/O LOGGING.
These tags provide fine-grained control over whether mail will be sent when a user runs a command by overriding the value of the mail_all_cmnds flag on a per-command basis. They have no effect when sudo is run with the -l or -v options. A NOMAIL tag will also override the mail_always and mail_no_perms options. For more information, see the descriptions of mail_all_cmnds, mail_always, and mail_no_perms in the SUDOERS OPTIONS section below.
By default, sudo requires that a user authenticate before running a command. This behavior can be modified via the NOPASSWD tag. Like a Runas_Spec, the NOPASSWD tag sets a default for the commands that follow it in the Cmnd_Spec_List. Conversely, the PASSWD tag can be used to reverse things. For example:
ray rushmore = NOPASSWD: /bin/kill, /bin/ls, /usr/bin/lprm
would allow the user ray to run /bin/kill, /bin/ls, and /usr/bin/lprm as root on the machine “rushmore” without authenticating himself. If we only want ray to be able to run /bin/kill without a password the entry would be:
ray rushmore = NOPASSWD: /bin/kill, PASSWD: /bin/ls, /usr/bin/lprm
Note, however, that the PASSWD tag has no effect on users who are in the group specified by the exempt_group setting.
By default, if the NOPASSWD tag is applied to any of a user's entries for the current host, the user will be able to run ‘sudo -l’ without a password. Additionally, a user may only run ‘sudo -v’ without a password if all of the user's entries for the current host have the NOPASSWD tag. This behavior may be overridden via the verifypw and listpw options.
These tags override the value of the setenv flag on a per-command basis. If SETENV has been set for a command, the user may disable the env_reset flag from the command line via the -E option. Additionally, environment variables set on the command line are not subject to the restrictions imposed by env_check, env_delete, or env_keep. As such, only trusted users should be allowed to set variables in this manner. If the command matched is ALL, the SETENV tag is implied for that command; this default may be overridden by use of the NOSETENV tag.
If sudo has been compiled with intercept support and the underlying operating system supports it, the INTERCEPT tag can be used to cause programs spawned by a command to be validated against sudoers and logged just like they would be if run through sudo directly. This is useful in conjunction with commands that allow shell escapes such as editors, shells, and paginators. There is additional overhead due to the policy check that may add latency when running commands such as shell scripts that execute a large number of sub-commands. For interactive commands, such as a shell or editor, the overhead is not usually noticeable.
In the following example, user chuck may run any command on the machine “research” in intercept mode.
chuck research = INTERCEPT: ALL
See the Preventing shell escapes section below for more details on how INTERCEPT works and whether or not it will work on your system.
sudo allows shell-style wildcards (aka meta or glob characters) to be used in host names, path names, and command line arguments in the sudoers file. Wildcard matching is done via the glob(3) and fnmatch(3) functions as specified by IEEE Std 1003.1 (“POSIX.1”).
These are not regular expressions. Unlike a regular expression there is no way to match one or more characters within a range.
Character classes may be used if your system's glob(3) and fnmatch(3) functions support them. However, because the ‘:’ character has special meaning in sudoers, it must be escaped. For example:
/bin/ls [[\:alpha\:]]*
Would match any file name beginning with a letter.
A forward slash (‘/’) will not be matched by wildcards used in the file name portion of the command. This is to make a path like:
/usr/bin/*
match /usr/bin/who but not /usr/bin/X11/xterm.
When matching the command line arguments, however, a slash does get matched by wildcards since command line arguments may contain arbitrary strings and not just path names.
Wildcards in command line arguments should be used with
care.
Wildcards can match any character, including white space. In most cases, it is
safer to use a regular expression to match command line arguments. For more
information, see Wildcards in command arguments below.
The following exceptions apply to the above rules:
Starting with version 1.9.10, it is possible to use regular expressions for path names and command line arguments. Regular expressions are more expressive than shell-style wildcards and are usually safer because they provide a greater degree of control when matching. The type of regular expressions supported by sudoers are POSIX extended regular expressions, similar to those used by the egrep(1) utility. They are usually documented in the regex(7) or re_format(7) manual, depending on the system. As an extension, if the regular expression begins with “(?i)”, it will be matched in a case-insensitive manner.
In sudoers, regular expressions must start with a ‘^’ character and end with a ‘$’. This makes it explicit what is, or is not, a regular expression. Either the path name, the command line arguments or both may be regular expressions. Because the path name and arguments are matched separately, it is even possible to use wildcards for the path name and regular expressions for the arguments. It is not possible to use a single regular expression to match both the command and its arguments. Regular expressions in sudoers are limited to 1024 characters.
There is no need to escape sudoers special characters in a regular expression other than the pound sign (‘#’).
In the following example, user john can run the passwd(1) command as root on any host but is not allowed to change root's password. This kind of rule is impossible to express safely using wildcards.
john ALL = /usr/bin/passwd ^[a-zA-Z0-9_]+$,\ !/usr/bin/passwd root
It is also possible to use a regular expression in conjunction with sudoedit rules. The following rule would give user bob the ability to edit the /etc/motd, /etc/issue, and /etc/hosts files only.
bob ALL = sudoedit ^/etc/(motd|issue|hosts)$
Regular expressions may also be used to match the command itself. In this example, a regular expression is used to allow user sid to run the /usr/sbin/groupadd, /usr/sbin/groupmod, /usr/sbin/groupdel, /usr/sbin/useradd, /usr/sbin/usermod, and /usr/sbin/userdel commands as root.
sid ALL = ^/usr/sbin/(group|user)(add|mod|del)$
One disadvantage of using a regular expression to match the command name is that it is not possible to match relative paths such as ./useradd or ../sbin/useradd. This has security implications when a regular expression is used for the command name in conjunction with the negation operator, ‘!’, as such rules can be trivially bypassed. Because of this, using a negated regular expression for the command name is strongly discouraged. This does not apply to negated commands that only use a regular expression to match the command arguments. See Regular expressions in command names below for more information.
It is possible to include other sudoers files from within the sudoers file currently being parsed using the @include and @includedir directives. For compatibility with sudo versions prior to 1.9.1, #include and #includedir are also accepted.
An include file can be used, for example, to keep a site-wide sudoers file in addition to a local, per-machine file. For the sake of this example the site-wide sudoers file will be /etc/sudoers and the per-machine one will be /etc/sudoers.local. To include /etc/sudoers.local from within /etc/sudoers one would use the following line in /etc/sudoers:
@include /etc/sudoers.local
When sudo reaches this line it will suspend processing of the current file (/etc/sudoers) and switch to /etc/sudoers.local. Upon reaching the end of /etc/sudoers.local, the rest of /etc/sudoers will be processed. Files that are included may themselves include other files. A hard limit of 128 nested include files is enforced to prevent include file loops.
Starting with version 1.9.1, the path to the include file may contain white space if it is escaped with a backslash (‘\’). Alternately, the entire path may be enclosed in double quotes (""), in which case no escaping is necessary. To include a literal backslash in the path, ‘\\’ should be used.
If the path to the include file is not fully-qualified (does not begin with a ‘/’), it must be located in the same directory as the sudoers file it was included from. For example, if /etc/sudoers contains the line:
@include sudoers.local
the file that will be included is /etc/sudoers.local.
The file name may also include the ‘%h’ escape, signifying the short form of the host name. In other words, if the machine's host name is “xerxes”, then
@include /etc/sudoers.%h
will cause sudo to include the file /etc/sudoers.xerxes.
The @includedir directive can be used to create a sudoers.d directory that the system package manager can drop sudoers file rules into as part of package installation. For example, given:
@includedir /etc/sudoers.d
sudo will suspend processing of the current file and read each file in /etc/sudoers.d, skipping file names that end in ‘~’ or contain a ‘.’ character to avoid causing problems with package manager or editor temporary/backup files.
Files are parsed in sorted lexical order. That is, /etc/sudoers.d/01_first will be parsed before /etc/sudoers.d/10_second. Be aware that because the sorting is lexical, not numeric, /etc/sudoers.d/1_whoops would be loaded after /etc/sudoers.d/10_second. Using a consistent number of leading zeroes in the file names can be used to avoid such problems. After parsing the files in the directory, control returns to the file that contained the @includedir directive.
Unlike files included via @include, visudo will not edit the files in a @includedir directory unless one of them contains a syntax error. It is still possible to run visudo with the -f flag to edit the files directly, but this will not catch the redefinition of an alias that is also present in a different file.
The pound sign (‘#’) is used to indicate a comment (unless it is part of a #include directive or unless it occurs in the context of a user name and is followed by one or more digits, in which case it is treated as a user-ID). Both the comment character and any text after it, up to the end of the line, are ignored.
The reserved word ALL is a built-in alias that always causes a match to succeed. It can be used wherever one might otherwise use a Cmnd_Alias, User_Alias, Runas_Alias, or Host_Alias. Attempting to define an alias named ALL will result in a syntax error. Using ALL can be dangerous since in a command context, it allows the user to run any command on the system.
The following option names permitted in an Option_Spec are also considered reserved words: CHROOT, TIMEOUT, CWD, NOTBEFORE and NOTAFTER. Attempting to define an alias with the same name as one of the options will result in a syntax error.
An exclamation point (‘!’) can be used as a logical not operator in a list or alias as well as in front of a Cmnd. This allows one to exclude certain values. For the ‘!’ operator to be effective, there must be something for it to exclude. For example, to match all users except for root one would use:
ALL, !root
If the ALL, is omitted, as in:
!root
it would explicitly deny root but not match any other users. This is different from a true “negation” operator.
Note, however, that using a ‘!’ in conjunction with the built-in ALL alias to allow a user to run “all but a few” commands rarely works as intended (see SECURITY NOTES below).
Long lines can be continued with a backslash (‘\’) as the last character on the line.
White space between elements in a list as well as special syntactic characters in a User Specification (‘=’, ‘:’, ‘(’, ‘)’) is optional.
The following characters must be escaped with a backslash (‘\’) when used as part of a word (e.g., a user name or host name): ‘!’, ‘=’, ‘:’, ‘,’, ‘(’, ‘)’, ‘\’.
sudo's behavior can be modified by Default_Entry lines, as explained earlier. A list of all supported Defaults parameters, grouped by type, are listed below.
Boolean Flags:
For this to work seamlessly, the operating system must support the automatic restarting of system calls. Unfortunately, not all operating systems do this by default, and even those that do may have bugs. For example, macOS fails to restart the tcgetattr(3) and tcsetattr(3) functions (this is a bug in macOS). Furthermore, because this behavior depends on the command stopping with the SIGTTIN or SIGTTOU signals, programs that catch these signals and suspend themselves with a different signal (usually SIGTOP) will not be automatically foregrounded. Some versions of the linux su(1) command behave this way. This flag is off by default.
This setting is only supported by version 1.8.7 or higher. It has no effect unless I/O logging is enabled or the use_pty flag is enabled.
This setting is only supported by version 1.9.10 or higher.
If the system is configured to use the /etc/hosts file in preference to DNS, the “canonical” host name may not be fully-qualified. The order that sources are queried for host name resolution is usually specified in the /etc/nsswitch.conf, /etc/netsvc.conf, /etc/host.conf, or, in some cases, /etc/resolv.conf file. In the /etc/hosts file, the first host name of the entry is considered to be the “canonical” name; subsequent names are aliases that are not used by sudoers. For example, the following hosts file line for the machine “xyzzy” has the fully-qualified domain name as the “canonical” host name, and the short version as an alias.
If the machine's hosts file entry is not formatted properly, the fqdn flag will not be effective if it is queried before DNS.
Beware that when using DNS for host name resolution, turning on fqdn requires sudoers to make DNS lookups which renders sudo unusable if DNS stops working (for example if the machine is disconnected from the network). Just like with the hosts file, you must use the “canonical” name as DNS knows it. That is, you may not use a host alias (CNAME entry) due to performance issues and the fact that there is no way to get all aliases from DNS.
This flag is off by default.
This setting is only supported by version 1.8.29 or higher.
This setting is only supported by version 1.8.29 or higher.
This setting is only supported by version 1.9.8 or higher.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.9.0 or higher.
The log_subcmds flag uses the same underlying mechanism as the intercept setting. See Preventing shell escapes for more information on what systems support this option and its limitations. This setting is only supported by version 1.9.8 or higher and is incompatible with SELinux RBAC support unless the system supports seccomp(2) filter mode.
If match_group_by_gid is enabled, group database lookups performed by sudoers will be keyed by group name as opposed to group-ID. On systems where there are multiple sources for the group database, it is possible to have conflicting group names or group-IDs in the local /etc/group file and the remote group database. On such systems, enabling or disabling match_group_by_gid can be used to choose whether group database queries are performed by name (enabled) or ID (disabled), which may aid in working around group entry conflicts.
The match_group_by_gid flag has no effect when sudoers data is stored in LDAP. This flag is off by default.
This setting is only supported by version 1.8.18 or higher.
This setting is only supported by version 1.9.8 or higher and is incompatible with SELinux RBAC support unless the system supports seccomp(2) filter mode.
This setting is only supported by version 1.9.8 or higher.
This setting is only supported by version 1.9.8 or higher.
The process will be stopped after execve(2) has completed but before the new command has had a chance to run. To verify the command, sudo will read the command's path from /proc/PID/exe, the command line arguments and environment from the process's memory, and compare them against the arguments that were passed to execve(2). In the event of a mismatch, the command will be sent a SIGKILL signal and terminated.
This can help prevent a time of check versus time of use issue with intercept mode where the execve(2) arguments could be altered after the sudoers policy check. The checks can only be performed if the proc(5) file system is available. This flag has no effect unless the intercept flag is enabled or the INTERCEPT tag has been set for the command and the intercept_type option is set to trace. This flag is on by default.
This setting is only supported by version 1.9.12 or higher.
This setting is only supported by version 1.9.10 or higher.
This setting is only supported by version 1.8.28 or higher.
This flag is off by default on systems other than Solaris.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.8.7 or higher.
This setting is only supported by version 1.8.8 or higher.
This setting is only supported by version 1.8.30 or higher. Older versions of sudo always allowed matching of unknown user and group IDs.
This setting is only supported by version 1.8.30 or higher.
This setting was first introduced in version 1.8.15 but initially suffered from a race condition. The check for symbolic links in writable intermediate directories was added in version 1.8.16.
This setting is only supported by version 1.8.15 or higher.
This setting is only supported by version 1.8.21 or higher.
This option has been superseded by the timestamp_type option.
A malicious program run under sudo may be capable of injecting commands into the user's terminal or running a background process that retains access to the user's terminal device even after the main program has finished executing. By running the command in a separate pseudo-terminal, this attack is no longer possible. This flag is off by default.
This setting is only supported by version 1.8.20 or higher.
Integers:
This setting is only supported by version 1.8.20 or higher.
This setting is only supported by version 1.9.0 or higher.
Once the local sequence number reaches the value of maxseq, it will “roll over” to zero, after which sudoers will truncate and re-use any existing I/O log path names.
This setting is only supported by version 1.8.7 or higher.
This setting is only supported by version 1.8.19 or higher.
Integers that can be used in a boolean context:
If umask is explicitly set in sudoers, it will override any umask setting in PAM or login.conf. If umask is not set in sudoers, the umask specified by PAM or login.conf will take precedence. The umask setting in PAM is not used for sudoedit, which does not create a new PAM session.
Strings:
The default is to use trace if it is supported by the system and dso if it is not.
The following percent (‘%’) escape sequences are supported:
In addition, any escape sequences supported by the system's strftime(3) function will be expanded.
To include a literal ‘%’ character, the string ‘%%’ should be used.
See the iolog_dir option above for a list of supported percent (‘%’) escape sequences.
In addition to the escape sequences, path names that end in six or more Xs will have the Xs replaced with a unique combination of digits and letters, similar to the mktemp(3) function.
If the path created by concatenating iolog_dir and iolog_file already exists, the existing I/O log file will be truncated and overwritten unless iolog_file ends in six or more Xs.
This setting is only supported by version 1.8.20 or higher.
This setting is only supported by version 1.8.19 or higher.
This setting is only supported by version 1.8.19 or higher.
This setting can be useful when the I/O logs are stored on a Network File System (NFS) share. Having a dedicated user own the I/O log files means that sudoers does not write to the log files as user-ID 0, which is usually not permitted by NFS.
This setting is only supported by version 1.8.19 or higher.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.9.9 or higher.
This setting is only supported by version 1.8.8 or higher.
This setting is only supported by version 1.8.8 or higher.
On systems that use PAM for authentication, passprompt will only be used if the prompt provided by the PAM module matches the string “Password: ” or “username's Password: ”. This ensures that the passprompt setting does not interfere with challenge-response style authentication. The passprompt_override flag can be used to change this behavior.
The default value is ‘Password: ’.
The default value is tty.
This setting is only supported by version 1.8.21 or higher.
The argument may be a double-quoted, space-separated list or a single value without double-quotes. The list can be replaced, added to, deleted from, or disabled by using the ‘=’, ‘+=’, ‘-=’, and ‘!’ operators respectively. Regardless of whether the env_reset option is enabled or disabled, variables specified by env_check will be preserved in the environment if they pass the aforementioned check. The global list of environment variables to check is displayed when sudo is run by root with the -V option.
Preserving the HOME environment variable has security implications since many programs use it when searching for configuration or data files. Adding HOME to env_keep may enable a user to run unrestricted commands via sudo and is strongly discouraged. Users wishing to edit files with sudo should run sudoedit (or sudo -e) to get their accustomed editor configuration instead of invoking the editor directly.
Server addresses should be of the form “host[:port][(tls)]”. The host portion may be a host name, an IPv4 address, or an IPv6 address in square brackets.
If the optional tls flag is present, the connection will be secured with Transport Layer Security (TLS) version 1.2 or 1.3. Versions of TLS prior to 1.2 are not supported.
If a port is specified, it may either be a port number or a well-known service name as defined by the system service name database. If no port is specified, port 30343 will be used for plaintext connections and port 30344 will be used for TLS connections.
When log_servers is set, event log data will be logged both locally (see the syslog and log_file settings) as well as remotely, but I/O log data will only be logged remotely. If multiple hosts are specified, they will be attempted in reverse order. If no log servers are available, the user will not be able to run a command unless either the ignore_iolog_errors flag (I/O logging enabled) or the ignore_log_errors flag (I/O logging disabled) is set. Likewise, if the connection to the log server is interrupted while sudo is running, the command will be terminated unless the ignore_iolog_errors flag (I/O logging enabled) or the ignore_log_errors flag (I/O logging disabled) is set.
This setting is only supported by version 1.9.0 or higher.
This setting is only supported by version 1.9.10 or higher.
The sudoers plugin supports its own plugin interface to allow non-Unix group lookups which can query a group source other than the standard Unix group database. This can be used to implement support for the nonunix_group syntax described earlier.
Group provider plugins are specified via the group_plugin setting. The argument to group_plugin should consist of the plugin path, either fully-qualified or relative to the /usr/local/libexec/sudo directory, followed by any configuration options the plugin requires. These options (if specified) will be passed to the plugin's initialization function. If options are present, the string must be enclosed in double quotes ("").
The following group provider plugins are installed by default:
Defaults group_plugin="group_file.so /etc/sudo-group"
Defaults group_plugin=system_group.so
The group provider plugin API is described in detail in sudo_plugin(5).
sudoers can log events in either JSON or sudo format, this section describes the sudo log format. Depending on sudoers configuration, sudoers can log events via syslog(3), to a local log file, or both. The log format is almost identical in both cases. Any control characters present in the log data are formatted in octal with a leading ‘#’ character. For example, a horizontal tab is stored as ‘#011’ and an embedded carriage return is stored as ‘#015’. In addition, space characters in the command path are stored as ‘#040’. Command line arguments that contain spaces are enclosed in single quotes (''). This makes it possible to distinguish multiple command line arguments from a single argument that contains spaces. Literal single quotes and backslash characters (‘\’) in command line arguments are escaped with a backslash.
Commands that sudo runs are logged using the following format (split into multiple lines for readability):
date hostname progname: username : TTY=ttyname ; CHROOT=chroot ; \ PWD=cwd ; USER=runasuser ; GROUP=runasgroup ; TSID=logid ; \ ENV=env_vars COMMAND=command
Where the fields are as follows:
Messages are logged using the locale specified by sudoers_locale, which defaults to the ‘C’ locale.
If the user is not allowed to run the command, the reason for the denial will follow the user name. Possible reasons include:
If an error occurs, sudoers will log a message and, in most cases, send a message to the administrator via email. Possible errors include:
By default, sudoers logs messages via syslog(3). The date, hostname, and progname fields are added by the system's syslog(3) function, not sudoers itself. As such, they may vary in format on different systems.
The maximum size of syslog messages varies from system to system. The syslog_maxlen setting can be used to change the maximum syslog message size from the default value of 980 bytes. For more information, see the description of syslog_maxlen.
If the logfile option is set, sudoers will log to a local file, such as /var/log/sudo. When logging to a file, sudoers uses a format similar to syslog(3), with a few important differences:
When I/O logging is enabled, sudo will runs the command in a pseudo-terminal, logging user input and/or output, depending on which sudoers flags are enabled. There are five distinct types of I/O that can be logged, each with a corresponding sudoers flag.
Type | Flag | Description |
terminal input | log_ttyin | keystrokes entered by the user |
terminal output | log_ttyout | command output displayed to the screen |
standard input | log_stdin | input from a pipe or a file |
standard output | log_stdout | output to a pipe or a file |
standard error | log_stderr | output to a pipe or a file |
In addition to flags described the above, the log_input flag and LOG_INPUT command tag set both log_ttyin and log_stdin. The log_output flag and LOG_OUTPUT command tag set log_ttyout, log_stdout, and log_stderr.
To capture terminal input and output, sudo run the command in a pseudo-terminal, logging the input and output before passing it on to the user. To capture the standard input, standard output or standard error, sudo uses a pipe to interpose itself between the input or output stream, logging the I/O before passing it to the other end of the pipe.
I/O can be logged either to the local machine or to a remote log server. For local logs, I/O is logged to the directory specified by the iolog_dir option (/var/log/sudo-io by default) using a unique session ID that is included in the sudo log line, prefixed with ‘TSID=’. The iolog_file option may be used to control the format of the session ID. For remote logs, the log_servers setting is used to specify one or more log servers running sudo_logsrvd or another server that implements the protocol described by sudo_logsrv.proto(5).
When logging standard input, anything sent to the standard input will be consumed, regardless of whether or not the command run via sudo is actively reading the standard input. This may have unexpected results when using sudo in a shell script that expects to process the standard input. For example, given the following shell script:
#!/bin/sh sudo echo testing echo done
It will behave as expected when the script is passed to the shell as a an argument:
$ sh test.sh testing done
However, if the script is passed to the shell on the standard input, the ‘sudo echo testing’ command will consume the rest of the script. This means that the ‘echo done’ statement is never executed.
$ sh -s < test.sh testing
There are several ways to work around this problem:
sudo echo testing < /dev/null
sh test.sh
Defaults!/bin/echo !log_stdin
Depending on the command, it may not be desirable to log the standard input or standard output. For example, I/O logging of commands that send or receive large amount of data via the standard output or standard input such as rsync(1) and tar(1) could fill up the log file system with superfluous data. It is possible to disable logging of the standard input and standard output for such commands as follows:
Cmnd_Alias COPY_CMDS = /usr/bin/tar, /usr/bin/cpio, /usr/bin/rsync # Log input and output but omit stdin and stdout when copying files. Defaults log_input, log_output Defaults!COPY_CMDS !log_stdin, !log_stdout
However, be aware that using the log_input flag or the LOG_INPUT command tag will also enable log_stdin. Likewise, the log_ouput flag or the LOG_OUTPUT command tag will enable log_stdout and log_stderr. Careful ordering of rules may be necessary to achieve the results that you expect.
For both local and remote I/O logs, each log is stored in a separate directory that contains the following files:
All files other than log are compressed in gzip format unless the compress_io flag has been disabled. Due to buffering, it is not normally possible to display the I/O logs in real-time as the program is executing. The I/O log data will not be complete until the program run by sudo has exited or has been terminated by a signal. The iolog_flush flag can be used to disable buffering, in which case I/O log data is written to disk as soon as it is available. The output portion of an I/O log file can be viewed with the sudoreplay(8) utility, which can also be used to list or search the available logs.
User input may contain sensitive information such as passwords (even if they are not echoed to the screen), which will be stored in the log file unencrypted. In most cases, logging the command output via log_output or LOG_OUTPUT is all that is required. When logging input, consider disabling the log_passwords flag.
Since each session's I/O logs are stored in a separate directory, traditional log rotation utilities cannot be used to limit the number of I/O logs. The simplest way to limit the number of I/O is by setting the maxseq option to the maximum number of logs you wish to store. Once the I/O log sequence number reaches maxseq, it will be reset to zero and sudoers will truncate and re-use any existing I/O logs.
Below are example sudoers file entries. Admittedly, some of these are a bit contrived. First, we allow a few environment variables to pass and then define our aliases:
# Run X applications through sudo; HOME is used to find the # .Xauthority file. Other programs use HOME to locate configuration # files and this may lead to privilege escalation! Defaults env_keep += "DISPLAY HOME" # User alias specification User_Alias FULLTIMERS = millert, mikef, dowdy User_Alias PARTTIMERS = bostley, jwfox, crawl User_Alias WEBADMIN = will, wendy, wim # Runas alias specification Runas_Alias OP = root, operator Runas_Alias DB = oracle, sybase Runas_Alias ADMINGRP = adm, oper # Host alias specification Host_Alias SPARC = bigtime, eclipse, moet, anchor :\ SGI = grolsch, dandelion, black :\ ALPHA = widget, thalamus, foobar :\ HPPA = boa, nag, python Host_Alias CUNETS = 128.138.0.0/255.255.0.0 Host_Alias CSNETS = 128.138.243.0, 128.138.204.0/24, 128.138.242.0 Host_Alias SERVERS = primary, mail, www, ns Host_Alias CDROM = orion, perseus, hercules # Cmnd alias specification Cmnd_Alias DUMPS = /usr/bin/mt, /usr/sbin/dump, /usr/sbin/rdump,\ /usr/sbin/restore, /usr/sbin/rrestore,\ sha224:0GomF8mNN3wlDt1HD9XldjJ3SNgpFdbjO1+NsQ== \ /home/operator/bin/start_backups Cmnd_Alias KILL = /usr/bin/kill Cmnd_Alias PRINTING = /usr/sbin/lpc, /usr/bin/lprm Cmnd_Alias SHUTDOWN = /usr/sbin/shutdown Cmnd_Alias HALT = /usr/sbin/halt Cmnd_Alias REBOOT = /usr/sbin/reboot Cmnd_Alias SHELLS = /usr/bin/sh, /usr/bin/csh, /usr/bin/ksh,\ /usr/local/bin/tcsh, /usr/bin/rsh,\ /usr/local/bin/zsh Cmnd_Alias SU = /usr/bin/su Cmnd_Alias PAGERS = /usr/bin/more, /usr/bin/pg, /usr/bin/less
Here we override some of the compiled in default values. We want sudo to log via syslog(3) using the auth facility in all cases and for commands to be run with the target user's home directory as the working directory. We don't want to subject the full time staff to the sudo lecture and we want to allow them to run commands in a chroot(2) “sandbox” via the -R option. User millert need not provide a password and we don't want to reset the LOGNAME or USER environment variables when running commands as root. Additionally, on the machines in the SERVERS Host_Alias, we keep an additional local log file and make sure we log the year in each log line since the log entries will be kept around for several years. Lastly, we disable shell escapes for the commands in the PAGERS Cmnd_Alias (/usr/bin/more, /usr/bin/pg and /usr/bin/less) . This will not effectively constrain users with sudo ALL privileges.
# Override built-in defaults Defaults syslog=auth,runcwd=~ Defaults>root !set_logname Defaults:FULLTIMERS !lecture,runchroot=* Defaults:millert !authenticate Defaults@SERVERS log_year, logfile=/var/log/sudo.log Defaults!PAGERS noexec
The User specification is the part that actually determines who may run what.
root ALL = (ALL) ALL %wheel ALL = (ALL) ALL
We let root and any user in group wheel run any command on any host as any user.
FULLTIMERS ALL = NOPASSWD: ALL
Full time sysadmins (millert, mikef, and dowdy) may run any command on any host without authenticating themselves.
PARTTIMERS ALL = ALL
Part time sysadmins bostley, jwfox, and crawl) may run any command on any host but they must authenticate themselves first (since the entry lacks the NOPASSWD tag).
jack CSNETS = ALL
The user jack may run any command on the machines in the CSNETS alias (the networks 128.138.243.0, 128.138.204.0, and 128.138.242.0). Of those networks, only 128.138.204.0 has an explicit netmask (in CIDR notation) indicating it is a class C network. For the other networks in CSNETS, the local machine's netmask will be used during matching.
lisa CUNETS = ALL
The user lisa may run any command on any host in the CUNETS alias (the class B network 128.138.0.0).
operator ALL = DUMPS, KILL, SHUTDOWN, HALT, REBOOT, PRINTING,\ sudoedit /etc/printcap, /usr/oper/bin/
The operator user may run commands limited to simple maintenance. Here, those are commands related to backups, killing processes, the printing system, shutting down the system, and any commands in the directory /usr/oper/bin/. One command in the DUMPS Cmnd_Alias includes a sha224 digest, /home/operator/bin/start_backups. This is because the directory containing the script is writable by the operator user. If the script is modified (resulting in a digest mismatch) it will no longer be possible to run it via sudo.
joe ALL = /usr/bin/su operator
The user joe may only su(1) to operator.
pete HPPA = /usr/bin/passwd [A-Za-z]*, !/usr/bin/passwd *root* %opers ALL = (: ADMINGRP) /usr/sbin/
Users in the opers group may run commands in /usr/sbin/ as themselves with any group in the ADMINGRP Runas_Alias (the adm and oper groups).
The user pete is allowed to change anyone's password except for root on the HPPA machines. Because command line arguments are matched as a single, concatenated string, the ‘*’ wildcard will match multiple words. This example assumes that passwd(1) does not take multiple user names on the command line. On systems with GNU getopt(3), options to passwd(1) may be specified after the user argument. As a result, this rule will also allow:
passwd username --expire
which may not be desirable.
bob SPARC = (OP) ALL : SGI = (OP) ALL
The user bob may run anything on the SPARC and SGI machines as any user listed in the OP Runas_Alias (root and operator.)
jim +biglab = ALL
The user jim may run any command on machines in the biglab netgroup. sudo knows that “biglab” is a netgroup due to the ‘+’ prefix.
+secretaries ALL = PRINTING, /usr/bin/adduser, /usr/bin/rmuser
Users in the secretaries netgroup need to help manage the printers as well as add and remove users, so they are allowed to run those commands on all machines.
fred ALL = (DB) NOPASSWD: ALL
The user fred can run commands as any user in the DB Runas_Alias (oracle or sybase) without giving a password.
john ALPHA = /usr/bin/su [!-]*, !/usr/bin/su *root*
On the ALPHA machines, user john may su to anyone except root but he is not allowed to specify any options to the su(1) command.
jen ALL, !SERVERS = ALL
The user jen may run any command on any machine except for those in the SERVERS Host_Alias (primary, mail, www, and ns).
jill SERVERS = /usr/bin/, !SU, !SHELLS
For any machine in the SERVERS Host_Alias, jill may run any commands in the directory /usr/bin/ except for those commands belonging to the SU and SHELLS Cmnd_Aliases. While not specifically mentioned in the rule, the commands in the PAGERS Cmnd_Alias all reside in /usr/bin and have the noexec option set.
steve CSNETS = (operator) /usr/local/op_commands/
The user steve may run any command in the directory /usr/local/op_commands/ but only as user operator.
matt valkyrie = KILL
On his personal workstation, valkyrie, matt needs to be able to kill hung processes.
WEBADMIN www = (www) ALL, (root) /usr/bin/su www
On the host www, any user in the WEBADMIN User_Alias (will, wendy, and wim), may run any command as user www (which owns the web pages) or simply su(1) to www.
ALL CDROM = NOPASSWD: /sbin/umount /CDROM,\ /sbin/mount -o nosuid\,nodev /dev/cd0a /CDROM
Any user may mount or unmount a CD-ROM on the machines in the CDROM Host_Alias (orion, perseus, hercules) without entering a password. This is a bit tedious for users to type, so it is a prime candidate for encapsulating in a shell script.
It is generally not effective to “subtract” commands from ALL using the ‘!’ operator. A user can trivially circumvent this by copying the desired command to a different name and then executing that. For example:
bill ALL = ALL, !SU, !SHELLS
Doesn't really prevent bill from running the commands listed in SU or SHELLS since he can simply copy those commands to a different name, or use a shell escape from an editor or other program. Therefore, these kind of restrictions should be considered advisory at best (and reinforced by policy).
In general, if a user has sudo ALL there is nothing to prevent them from creating their own program that gives them a root shell (or making their own copy of a shell) regardless of any ‘!’ elements in the user specification.
If the fast_glob option is in use, it is not possible to reliably negate commands where the path name includes globbing (aka wildcard) characters. This is because the C library's fnmatch(3) function cannot resolve relative paths. While this is typically only an inconvenience for rules that grant privileges, it can result in a security issue for rules that subtract or revoke privileges.
For example, given the following sudoers file entry:
john ALL = /usr/bin/passwd [a-zA-Z0-9]*, /usr/bin/chsh [a-zA-Z0-9]*,\ /usr/bin/chfn [a-zA-Z0-9]*, !/usr/bin/* root
User john can still run ‘/usr/bin/passwd root’ if fast_glob is enabled by changing to /usr/bin and running ‘./passwd root’ instead.
Another potential issue is that when sudo executes the command, it must use the command or path specified by the user instead of a path listed in the sudoers file. This may lead to a time of check versus time of use race condition.
Command line arguments are matched as a single, concatenated string. This mean a wildcard character such as ‘?’ or ‘*’ will match across word boundaries, which may be unexpected. For example, while a sudoers entry like:
%operator ALL = /bin/cat /var/log/messages*
will allow command like:
$ sudo cat /var/log/messages.1
It will also allow:
$ sudo cat /var/log/messages /etc/shadow
which is probably not what was intended. A safer alternative is to use a regular expression for matching command line arguments. The above example can be rewritten as a regular expression:
%operator ALL = /bin/cat ^/var/log/messages[^[:space:]]*$
The regular expression will only match a single file with a name that begins with /var/log/messages and does not include any white space in the name. It is often better to do command line processing outside of the sudoers file in a scripting language for anything non-trivial.
Using a regular expression to match a command name has the same security implications as using the fast_glob option:
These issues do not apply to rules where only the command line options are matched using a regular expression.
Once sudo executes a program, that program is free to do whatever it pleases, including run other programs. This can be a security issue since it is not uncommon for a program to allow shell escapes, which lets a user bypass sudo's access control and logging. Common programs that permit shell escapes include shells (obviously), editors, paginators, mail, and terminal programs.
There are four basic approaches to this problem:
There are two underlying mechanisms that may be used to implement intercept mode: dso and trace. The intercept_type setting can be used to select between them.
The first mechanism, dso, overrides the standard C library functions that are used to execute a command. It does this by setting an environment variable (usually LD_PRELOAD) to the path of a dynamic shared object, or shared library, containing custom versions of the execve(2), execl(3), execle(3), execlp(3), execv(3), execvp(3), execvpe(3), and system(3) library functions that connect back to sudo for a policy decision. Note, however, that this applies only to dynamically-linked executables. It is not possible to intercept commands for statically-linked executables or executables that run under binary emulation this way. Because most dynamic loaders ignore LD_PRELOAD (or the equivalent) when running set-user-ID and set-group-ID programs, sudoers will not permit such programs to be run in intercept mode by default. The dso mechanism is incompatible with sudo's SELinux RBAC support (but see below). SELinux disables LD_PRELOAD by default and interferes with file descriptor inheritance, which sudo relies on.
The second mechanism, trace, is available on Linux systems that support seccomp(2) filtering. It uses ptrace(2) and seccomp(2) to intercept the execve(2) system call instead of pre-loading a dynamic shared object. Both static and dynamic executables are supported and it is compatible with sudo's SELinux RBAC mode. Functions utilizing the execveat(2) system call, such as fexecve(3), are not currently intercepted.
The intercept feature is known to work on Solaris, *BSD, Linux, macOS, HP-UX 11.x and AIX 5.3 and above. It should be supported on most operating systems that support the LD_PRELOAD environment variable or an equivalent. It is not possible to intercept shell built-in commands or restrict the ability to read or write sensitive files from within a shell.
To enable intercept mode on a per-command basis, use the INTERCEPT tag as documented in the User Specification section above. Here is that example again:
chuck research = INTERCEPT: ALL
This allows user chuck to run any command on the machine “research” in intercept mode. Any commands run via shell escapes will be validated and logged by sudo. If you are unsure whether or not your system is capable of supporting intercept, you can always just try it out and check whether or not external commands run via a shell are logged when intercept is enabled.
There is an inherent race condition between when a command is checked against sudoers rules and when it is actually executed. If a user is allowed to run arbitrary commands, they may be able to change the execve(2) arguments in the program after the sudoers policy check has completed but before the new command is executed. Starting with version 1.9.12, the trace method will verify that the command and its arguments have not changed after execve(2) has completed but before execution of the new program has had a chance to run. This is not the case with the dso method. See the description of the intercept_verify setting for more information.
To enable noexec for a command, use the NOEXEC tag as documented in the User Specification section above. Here is that example again:
aaron shanty = NOEXEC: /usr/bin/more, /usr/bin/vi
This allows user aaron to run /usr/bin/more and /usr/bin/vi with noexec enabled. This will prevent those two commands from executing other commands (such as a shell). If you are unsure whether or not your system is capable of supporting noexec you can always just try it out and check whether shell escapes work when noexec is enabled.
Restricting shell escapes is not a panacea. Programs running as root are still capable of many potentially hazardous operations (such as changing or overwriting files) that could lead to unintended privilege escalation. In the specific case of an editor, a safer approach is to give the user permission to run sudoedit (see below).
The sudoers plugin includes sudoedit support which allows users to securely edit files with the editor of their choice. As sudoedit is a built-in command, it must be specified in the sudoers file without a leading path. However, it may take command line arguments just as a normal command does. Wildcards used in sudoedit command line arguments are expected to be path names, so a forward slash (‘/’) will not be matched by a wildcard.
Unlike other sudo commands, the editor is run with the permissions of the invoking user and with the environment unmodified. More information may be found in the description of the -e option in sudo(8).
For example, to allow user operator to edit the “message of the day” file on any machine:
operator ALL = sudoedit /etc/motd
The operator user then runs sudoedit as follows:
$ sudoedit /etc/motd
The editor will run as the operator user, not root, on a temporary copy of /etc/motd. After the file has been edited, /etc/motd will be updated with the contents of the temporary copy.
Users should never be granted sudoedit permission to edit a file that resides in a directory the user has write access to, either directly or via a wildcard. If the user has write access to the directory it is possible to replace the legitimate file with a link to another file, allowing the editing of arbitrary files. To prevent this, starting with version 1.8.16, symbolic links will not be followed in writable directories and sudoedit will refuse to edit a file located in a writable directory unless the sudoedit_checkdir option has been disabled or the invoking user is root. Additionally, in version 1.8.15 and higher, sudoedit will refuse to open a symbolic link unless either the sudoedit_follow option is enabled or the sudoedit command is prefixed with the FOLLOW tag in the sudoers file.
sudoers will check the ownership of its time stamp directory (/var/db/sudo/ts by default) and ignore the directory's contents if it is not owned by root or if it is writable by a user other than root. Older versions of sudo stored time stamp files in /tmp; this is no longer recommended as it may be possible for a user to create the time stamp themselves on systems that allow unprivileged users to change the ownership of files they create.
While the time stamp directory should be cleared at reboot time, not all systems contain a /run or /var/run directory. To avoid potential problems, sudoers will ignore time stamp files that date from before the machine booted on systems where the boot time is available.
Some systems with graphical desktop environments allow unprivileged users to change the system clock. Since sudoers relies on the system clock for time stamp validation, it may be possible on such systems for a user to run sudo for longer than timestamp_timeout by setting the clock back. To combat this, sudoers uses a monotonic clock (which never moves backwards) for its time stamps if the system supports it.
sudoers will not honor time stamps set far in the future. Time stamps with a date greater than current_time + 2 * TIMEOUT will be ignored and sudoers will log and complain.
If the timestamp_type option is set to “tty”, the time stamp record includes the device number of the terminal the user authenticated with. This provides per-terminal granularity but time stamp records may still outlive the user's session.
Unless the timestamp_type option is set to “global”, the time stamp record also includes the session ID of the process that last authenticated. This prevents processes in different terminal sessions from using the same time stamp record. On systems where a process's start time can be queried, the start time of the session leader is recorded in the time stamp record. If no terminal is present or the timestamp_type option is set to “ppid”, the start time of the parent process is used instead. In most cases this will prevent a time stamp record from being re-used without the user entering a password when logging out and back in again.
Versions 1.8.4 and higher of the sudoers plugin support a flexible debugging framework that can help track down what the plugin is doing internally if there is a problem. This can be configured in the sudo.conf(5) file.
The sudoers plugin uses the same debug flag format as the sudo front-end: subsystem@priority.
The priorities used by sudoers, in order of decreasing severity, are: crit, err, warn, notice, diag, info, trace, and debug. Each priority, when specified, also includes all priorities higher than it. For example, a priority of notice would include debug messages logged at notice and higher.
The following subsystems are used by the sudoers plugin:
For example:
Debug sudoers.so /var/log/sudoers_debug match@info,nss@info
For more information, see the sudo.conf(5) manual.
ssh(1), su(1), fnmatch(3), glob(3), mktemp(3), strftime(3), sudo.conf(5), sudo_plugin(5), sudoers.ldap(5), sudoers_timestamp(5), sudo(8), visudo(8)
Many people have worked on sudo over the years; this version consists of code written primarily by:
See the CONTRIBUTORS.md file in the sudo distribution (https://www.sudo.ws/about/contributors/) for an exhaustive list of people who have contributed to sudo.
The sudoers file should always be edited by the visudo utility which locks the file and checks for syntax errors. If sudoers contains syntax errors, sudo may refuse to run, which is a serious problem if sudo is your only method of obtaining superuser privileges. Recent versions of sudoers will attempt to recover after a syntax error by ignoring the rest of the line after encountering an error. Older versions of sudo will not run if sudoers contains a syntax error.
When using netgroups of machines (as opposed to users), if you store fully qualified host name in the netgroup (as is usually the case), you either need to have the machine's host name be fully qualified as returned by the hostname command or use the fqdn option in sudoers.
If you believe you have found a bug in sudo, you can submit a bug report at https://bugzilla.sudo.ws/
Limited free support is available via the sudo-users mailing list, see https://www.sudo.ws/mailman/listinfo/sudo-users to subscribe or search the archives.
sudo is provided “AS IS” and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. See the LICENSE.md file distributed with sudo or https://www.sudo.ws/about/license/ for complete details.
January 16, 2023 | Sudo 1.9.13p2 |