|PERIODIC.CONF(5)||File Formats Manual||PERIODIC.CONF(5)|
periodic job configuration information
periodic.conf contains a
description of how daily, weekly and monthly system maintenance jobs should
run. It resides in the /etc/defaults directory and
parts may be overridden by a file of the same name in
/etc, which itself may be overridden by the
periodic.conf file is actually sourced
as a shell script from each of the periodic scripts and is intended to
simply provide default configuration variables.
The following variables are used by periodic(8) itself:
For an unattended machine, suitable values for
and monthly_output might be
respectively, as newsyslog(8)
will rotate these files (if they exists) at the appropriate times.
NO”, periodic(8) will mask the script's output. If the return code of a script is ‘1’ and ⟨dir⟩_show_info is set to “
NO”, periodic(8) will mask the script's output. If the return code of a script is ‘2’ and ⟨dir⟩_show_badconfig is set to “
NO”, periodic(8) will mask the script's output. If these variables are set to neither “
YES” nor “
NO”, they default to “
YES” and “
Refer to the periodic(8) manual page for how script return codes are interpreted.
The following variables are used by the standard scripts that reside in /etc/periodic/daily:
YES” if you want to clear temporary directories daily.
YES”. Wild card characters are permitted.
YES” if you want the removed files to be reported in your daily output.
The following variables are used by the standard scripts that reside in /etc/periodic/weekly:
The following variables are used by the standard scripts that reside in /etc/periodic/monthly:
periodic.conf file appeared in
Brian Somers ⟨brian@Awfulhak.org⟩
|May 12, 2007||macOS 14.1|