|PAM.CONF(5)||File Formats Manual||PAM.CONF(5)|
pam.conf — PAM
policy file format
The PAM library searches for policies in the following files, in decreasing order of preference:
If none of these locations contains a policy for the given
default policy is used instead, if it
Entries in per-service policy files must be of one of the two forms below:
function-class control-flag module-path [arguments ...] function-class
Entries in pam.conf-style policy files are of the same form, but are prefixed by an additional field specifying the name of the service they apply to.
In both types of policy files, blank lines are ignored, as is
anything to the right of a ‘
The function-class field specifies the class of functions the entry applies to, and is one of:
The control-flag field determines how the result returned by the module affects the flow of control through (and the final result of) the rest of the chain, and is one of:
The module-path field specifies the name, or optionally the full path, of the module to call.
The remaining fields are passed as arguments to the module if and when it is invoked.
include form of entry causes entries
from a different chain (specified by
other-system-name) to be included in the current one.
This allows one to define system-wide policies which are then included into
service-specific policies. The system-wide policy can then be modified
without having to also modify each and every service-specific policy.
X/Open Single Sign-On Service (XSSO) - Pluggable Authentication Modules, June 1997.
The OpenPAM library was developed for the FreeBSD Project by ThinkSec AS and Network Associates Laboratories, the Security Research Division of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
This manual page was written by Dag-Erling Smørgrav ⟨des@FreeBSD.org⟩.
|June 16, 2005||macOS 14.1|