|NEWSYSLOG.CONF(5)||File Formats Manual||NEWSYSLOG.CONF(5)|
newsyslog.conf file is used to set log
file rotation configuration for the
newsyslog(8) utility. Configuration
may designate that logs are rotated based on size, last rotation time, or
time of day. The
newsyslog.conf file can also be
used to designate secure permissions to log files at rotation time. During
initialization, newsyslog(8) reads a
configuration file, normally /etc/newsyslog.conf, to
determine which logs may potentially be rotated and archived. Each line has
five mandatory fields and four optional fields, separated with whitespace.
Blank lines or lines beginning with
#’ are ignored. If
#’ is placed in the middle of the
line, the ‘
#’ character and the rest
of the line after it is ignored. To prevent special meaning, the
#’ character may be escaped with
\’; in this case preceding
\’ is removed and
#’ is treated as an ordinary
character. The fields of the configuration file are as follows:
default⟩”. The special default entry will only be used if a log file name is given as a command line argument to newsyslog(8), and if that log file name is not matched by any other line in the configuration file.
:’ is essential regardless if the owner or group field is left blank or contains a value. The field may be numeric, or a name which is present in /etc/passwd or /etc/group. By default, log files are owned by root:admin.
*’), the log file will not be trimmed based on size.
*’), log rotation will solely depend on the contents of the size field. Otherwise, the when field consists of an optional interval in hours, usually followed by an ‘
@’-sign and a time in restricted ISO 8601 format. Additionally, the format may also be constructed with a ‘
$’ sign along with a rotation time specification of once a day, once a week, or once a month.
If a time is specified, the log file will only be trimmed if newsyslog(8) is run within one hour of the specified time. If an interval is specified, the log file will be trimmed if that many hours have passed since the last rotation. When both a time and an interval are specified then both conditions must be satisfied for the rotation to take place.
There is no provision for the specification of a timezone. There is little point in specifying an explicit minutes or seconds component in the current implementation, since the only comparison is “within the hour”.
The lead-in character for a restricted ISO 8601 time is an
@’ sign. The particular format of
the time in restricted ISO 8601 is:
Optional date fields default to the appropriate component of the current
date; optional time fields default to midnight; hence if today is
January 22, 1999, the following date specifications are all
The lead-in character for day, week, and month specification
is a ‘
$’ sign. The particular
format of day, week, and month specification is:
respectively. Optional time fields default to midnight. The ranges for
day and hour specifications are:
L’ or ‘
l’ to specify the last day of the month.
Bis specified, then that informational message will not be inserted into the log file.
-Coption was also specified on the command line.
UF_NODUMPflag when creating a new version of this log file. This option would affect how the dump(8) command treats the log file when making a file system backup.
Uflag was specified. If this field is present, a signal_number is sent the process ID contained in this file. If this field is not present, then a
SIGHUPsignal will be sent to syslogd(8), unless the
Nflag has been specified. This field must start with ‘
/’ in order to be recognized properly.
Uflag was specified). If this field is not present, then a
SIGHUPsignal will be sent.
This manual page first appeared in FreeBSD 4.10.
|November 27, 2006||macOS 14.1|